Back to overview
Resolved
Migrating from Selfhosted Emails to Zoho
Sep 19, 2026 at 2:04pm UTC
–
Sep 20, 2026 at 8:00am UTC
Affected services
Leadership E-Mails
Resolved
Sep 20, 2026 at 8:00am UTC
Maintenance ended
Affected services
Updated
Sep 19, 2026 at 3:46pm UTC
Everything is setup. Leadership only needs to sign in & the records only need to propagate. I will not end this maintenance, as it will end itself automatically so we can give it a buffer to propagate.
Affected services
Created
Sep 19, 2026 at 2:04pm UTC
I really love our emails, but our spam is just too much.
Affected services