Some services are currently unavailable
Resolved
Aug 4, 2026 at 11:04pm UTC
myTools is expected to be down for a while, we're moving to a Maintenance report for that service.
Affected services
Updated
Aug 4, 2026 at 7:52pm UTC
Our E-Learning Hub is now also online again! MyTools will stay be down until Development has finished.
Affected services
Updated
Aug 3, 2026 at 7:50pm UTC
Support is back online! Other services are still down until further notice.
Affected services
Updated
Aug 3, 2026 at 6:15pm UTC
Huge progress has been made over these last few hours. Support and our E-Learning Platform are both almost ready. We expect to get Support online later today and our E-Learning Platform later tommorow.
Affected services
Updated
Aug 2, 2026 at 10:45pm UTC
Support is taking longer than expected due to some issues, we're looking at other systems at the moment.
Affected services
Updated
Aug 2, 2026 at 1:45pm UTC
Support is now fully down while we're switching to another Support Service
Affected services
Created
Aug 1, 2026 at 10:46pm UTC
Our Support & some other services are currently down until further notice, myTickets has been added in the meantime for tickets.
Affected services